YOUR STORY PLAYS HERE
Home » Categories » Multiple Categories

Playback of files in Cablecast is stuttering consistently.

Applies to

  • Cablecast version < 6.0.6

Symptoms

  • Playback of files is consistently stuttering.
  • Restarting the server can make it behave better for a few hours, then the stuttering returns.
  • The TRMS event log in the event viewer shows the file validation process processing the same file(s) recurrently.

Cause

We have seen issues where the file validation indexer process is stuck processing files in a loop. This essentially results in the server endlessly parsing some files as if they were newly-added content, causing enough of a resource drain to negatively affect live playbacks and encodes on the SX server.

Resolution

This has been resolved in Cablecast versions > 6.0.5.

Notes

The file validation indexer service performs a number of operations on any new asset file ingested into the server. The file validation's goal is to decide whether or not the new asset file meets the server's requirements, and extract data to enable playback optimizations. It accomplishes this through the following tasks:

  • Gets the basic file information, such as video track resolution, codec, bitrate. Audio codec, bitrate, samples per second. Will reject any file that doesn't meet the server's specified video and audio requirements, based on the server's currently set IO resolution. 
  • Extracts AFD code from the asset file. If no AFD code is found the server will inject default AFD codes into the playback output.
  • Generates thumbnails from the asset file. 
  • Create index files to speed up mpeg file reading. 
  • Read and decode content from the file at a few predetermined different positions. This is to maximize our chances of detecting incorrect file formatting issues.

If any of the above checks fail (except AFD checks), the file information indexer will reject the file and Cablecast will remove it from the new asset content queue. 

Unfortunately it is not possible to easily identify which of the above step(s) failed just by looking at the event viewer and log files. If this problem happens frequently there may be a problem with how files are imported into the server (resulting in truncated/partially copied asset files), and further investigation may be necessary by the support team.

In the case of this specific article, the new asset content is invalid but is never removed from the content queue, and reprocessing the file indefinitely caused detrimental performance issues.

Custom Fields
  • Bug Status: NA
  • Internal Bug ID: 9991, 9576
0 (0)
Article Rating (No Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Cablecast 5.2.12 is Released
Viewed 822 times since Fri, Oct 30, 2015
Mixing 720p and 1080i content on my HD SX Server
Viewed 1463 times since Mon, Sep 22, 2014
Cablecast attempts to read AFD data from unsupported files
Viewed 953 times since Wed, Mar 11, 2015
Windows Update Driver Searching Interferes with Matrox Driver Upgrade
Viewed 867 times since Wed, Dec 30, 2015
Cablecast 5.3.7 is Released
Viewed 872 times since Fri, Oct 30, 2015
Cablecast 5.3.8 is Released
Viewed 1005 times since Sat, Dec 5, 2015
When accessing Frontdoor, I get an "HTTP Error 404.2 – Not Found" error
Viewed 2056 times since Mon, Mar 2, 2015
Tightrope Media Systems Software End of Life Policy
Viewed 2771 times since Wed, Dec 17, 2014