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My Brightsign Player is showing a black screen

Applies to

  • Carousel version 6.4.6+
  • Carousel For Brightsign

Symptoms

  • Brightsign player shows a black screen after setup

Cause

There could be a few causes for this behavior:

1) No player license on the server

2) Screen resolution incompatible with the display

3) Player unable to reach server

4) Player was configured improperly 

Resolution

1) Log into Front Door>Server Setup>Licensing and check to make sure that you have at least one player license available. If not, contact support@trms.com

2) If the channel resolution is set to 1920x1080, the default setting used for the player is going to be 1080p (Not 1080i). Make sure that your display(or encoder etc.) is compatible with this resolution

3) Check with your network administrator and make sure that the player is able to communicate with the server.

4) Go through the quick start guide from the beginning. Often times a step is missed and unless all of the steps are completed properly, the player will not work. Be sure to FORMAT THE SD CART TO FAT 32 before you run the Bright Config application or it will not work. Also, be sure to download the most current version of the Brightsign deployment tool for the Carousel server as well as the Bright Config application from http://www.trms.com/support/brightsign in order to ensure you have the most recent software revisions.

 

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