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MPEG Files remain processing and never finish

Applies to

  • Cablecast 6.0 +
  • Cablecast 6.1 +

Symptoms

  • MPEG files on a a standalone video server hosting the Cablecast UI stay stuck in processing indefinitely.
  • No XML or thumbnails in the metadata folder.
  • No error logs in the event viewer.
  • When running DEBUG Viewer you will see an exception when parsing a boolean value failed.
  • The files in question are MPEG, and stored on a video server hosting the Cablecast UI.

Cause

The Cablecast UI incorrectly sets an environment variable used when indexing files to a bad value. The environment variable in questions is  "CABLECAST_INDEX_MPEG". The correct value for this variable is either "True" or "False". Any other value will cause a parsing error which happens early in the file indexing process. This causes the file to never index.

Resolution

Stop all services (Cablecast and Cablecast Device Control) and stop IIS. Then replace the "CablecastSettings.dll" attached to this KB in the following locations:

  • C:\TRMS\Web\CablecastAPI\bin
  • C:\TRMS\Web\CablecastWS\bin

Next fix the environment variable by right clicking "Computer" and choose properties. Click "Advanced System Settings" and then under the "Advanced" tab click "Environment Variables". Find the "CABLECAST_INDEX_MPEG" environment variable and edit it. Replace the value with "True" (No quotes). Start the services and IIS and the files should index properly with in a few minutes.

Additional Information

This will be fixed in Cablecast 6.0.9 and 6.0.5.

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