YOUR STORY PLAYS HERE
Home » Categories » Multiple Categories

Missing mp4 MIME type prevents VOD files from loading in On Demand Player

Applies to

  • Cablecast 5.2.0+

Symptoms

  • VOD files fail to load in the On Demand Player.
  • On Demand Player appears on the page, but continues loading at 00:00

Cause

This issue may be caused by a missing mp4 MIME type in Internet Information Services.

Workaround - Windows 7 / Server 2008 R2

 

From the Windows Desktop of your VOD server:

  1. Right Click Computer
  2. Select Manage
  3. Expand the Services and Applications node (Windows 7) or the Roles node (Server 2008 R2)
  4. Expand the Web Server (IIS) node (This step can be skipped on Windows 7)
  5. Select Internet Information Services
  6. Expand the node for your server in the Connections list
  7. Expand the Sites node
  8. Expand the Default Web Site node
  9. Select the vod Virtual Directory
  10. Scroll to IIS in the right pane
  11. Double-click MIME Types
  12. Confirm that this list DOES NOT include .mp4
  13. Click Add if .mp4 is not included in the list
  14. Enter .mp4 for the file extension 
  15. Enter video/mp4 for the MIME type
  16. Press OK

Additional Information

We have had reports that this MIME type sometimes gets removed from a system for unknown reasons.  We are investigating why this could be happening and will update this article accordingly.

PendingThis software behavior may be the result of a bug.  It has been assigned case number 8699.

Custom Fields
  • Bug Status: Pending
  • Internal Bug ID: 8699
0 (0)
Article Rating (No Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Live Streams cannot be viewed full-screen in Internet Explorer 11
Viewed 1651 times since Mon, Oct 6, 2014
2:3 Pull down files.
Viewed 1495 times since Fri, Jul 10, 2015
Customizing your Cablecast Screenweave Account
Viewed 461 times since Thu, Aug 2, 2018
Added IP control of routers using the LeitchRouterCM
Viewed 1944 times since Thu, Sep 18, 2014
Issues Scheduling Cablecast When Daylight Savings Time Changes
Viewed 1034 times since Tue, Mar 7, 2017
Saved Searches are not migrated when upgrading from Cablecast 5.x to newer versions
Viewed 1143 times since Thu, Jul 23, 2015
How to I find my Cablecast Channel ID’s for use with the Web API
Viewed 1541 times since Thu, Jul 23, 2015
MPEG Files remain processing and never finish
Viewed 1453 times since Thu, Oct 13, 2016
DVD Import
Viewed 2860 times since Fri, Jun 12, 2015