YOUR STORY PLAYS HERE
Home » Categories » Multiple Categories

Known Issues With Carousel 7 Installer

Issues Affecting Carousel 7.0.3

This document describes known issues with installing Carousel 7 as well as workarounds. It will be updated for each release of Carousel 7 as fixes are released to address various issues. This document currently covers issues when installing Carousel 7.0.3.

Offline Server Installs Fail To Configure Required IIS Packages

  • Internal Bug ID: 10298

Symptoms

Installer will fail when doing offline installs on new systems without internet connections. The installer failure will usually references IIS_NETFX35.

Cause

Internally, the installer is trying to enable certain operating system features that require downloading installation media from Microsoft. Without an internet connection, these media downloads fail, and the install cannot configure.

Workaround

  • In Windows, Search / Run Dialog enter "Add Remove Programs" to open the "Add / Remove Programs" control panel
  • Select the option for Installing optional Windows features.
  • Enable .NET 3.5 and the following options from Internet Information Systems

 

New Installs Fail To Run Frontdoor SQL Scripts If SQL Server Is Not Already Installed

  • Internal Bug ID: 10296

Symptoms

Installer will complete successfully, but users will be unable to login. An error indicating missing SQL objects such as "dbo.ServerSettings" will be shown when attempting to login.

 

Cause

The suspected cause is that SQL is not ready to run commands when first installed, and the Carousel installer moves too quickly from installing SQL Server to installing Frontdoor.

Workaround

  1. Manually Run the Frontdoor SQL Script located in C:\TRMS\Database\Frontdoor-Populate.sql

 

 

New Installs May Not Configure IIS Properly

  • Internal Bug ID: 10297
  • Only recreated on Windows 7
  • Does not seem to affect Windows 10

Symptoms

Installer will complete successfully but user will not be able to login due to a IIS error including a 404.17 error mentioning a Static File Handler

 

Workaround

  • Right click on My Computer and choose Manage
  • Find the Management Pane for Internet Information Services (IIS)
  • Select the top most server node
  • Under ISAPI and CGI Restrictions ensure ASP.NET 4 filters are "Allowed" and not "Disabled"

Save

0 (0)
Article Rating (No Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
About Tightrope’s software version numbers
Viewed 2592 times since Wed, Dec 17, 2014
Carousel for BrightSign software version release history
Viewed 1049 times since Thu, Aug 20, 2015
My new Carousel player will not connect to my server
Viewed 2032 times since Tue, Nov 11, 2014
Dynamic Instagram via third-party API Intergration
Viewed 470 times since Thu, Apr 20, 2017
My weather isn’t updating in Carousel
Viewed 2147 times since Mon, Sep 22, 2014
Channel Showing Black When Switching To Carousel
Viewed 1946 times since Mon, Jun 29, 2015
Where can I download Carousel virtual machine images?
Viewed 1308 times since Tue, Dec 8, 2015
When accessing Frontdoor, I get an "HTTP Error 404.2 – Not Found" error
Viewed 1960 times since Mon, Mar 2, 2015