YOUR STORY PLAYS HERE
Home » Categories » Cablecast

How to Adjust the Maximum Number of Results Returned by the Cablecast Web Service

Applies to

  • Cablecast (All Versions)

Symptoms

  • The Cablecast Web Service only returns 50 results for Show searches

Cause

In order to prevent some Web Service queries from using excessive system resources, the maximum number of results is intentionally limited.

Resolution

You can modify the setting that determines the  maximum number of results using the following procedure:

  1. From the Windows desktop of the server hosting the Cablecast Web Service:
  2. Navigate to either C:\TRMS\Web\CablecastWS\ or D:\TRMS\Web\CablecastWS (on older machines this folder will be on the D: drive)
  3. Open web.config using Notepad or a similar text editor
    * Make sure you're editing web.config not web.config.latest
  4. Under the <appSettings> section look for a setting called "ShowResultLimitPerSite"
  5. Change the number to your desired value.  Note that the default value is 50. 
  6. Save the file

Example:

To set the limit at 100 shows the line would read:

<add key="ShowResultLimitPerSite" value="100" />

Please note that setting this value too high will cause the Web Service to use more system resources.  This might cause undesired side effects.

0 (0)
Article Rating (No Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Cablecast 5.2.12 is Released
Viewed 1118 times since Fri, Oct 30, 2015
Tightrope Media Systems Software End of Life Policy
Viewed 3897 times since Wed, Dec 17, 2014
Cablecast RTP Streaming Feature Overview
Viewed 1953 times since Wed, Dec 13, 2017
Added IP control of routers using the LeitchRouterCM
Viewed 1829 times since Thu, Sep 18, 2014
Contact information not being saved for automatic database back ups
Viewed 1854 times since Mon, Oct 6, 2014
Notes for using Utah Scientific routers with Cablecast
Viewed 1901 times since Fri, Jan 9, 2015
Issues Scheduling Cablecast When Daylight Savings Time Changes
Viewed 923 times since Tue, Mar 7, 2017
Cablecast - Hardware Warranty Terms
Viewed 996 times since Mon, Feb 20, 2017
can’t delete files on the content drive, user doesn’t have permission to delete files error
Viewed 966 times since Mon, Jan 16, 2017