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FrontDoor fails to backup Carousel database

Applies to

  • Carousel 7.0.0 - 7.0.2

Symptoms

  • You receive an error stating "Could not back up database carousel50;multipleactiveresultsets=true. Incorrect syntax near 'multipleactiveresultsets'...."

Cause

This issue is caused by a software bug within the FrontDoor application.  The piece of code that detects the name of the Carousel database within SQL server is incorrectly interpreting the database name as "carousel50;multipleactiveresultsets=true" instead of "carousel50"

Workaround

  1. From the Windows desktop of your server navigate to C:\TRMS\Configuration\ 

    If you don't see a C:\TRMS\Configuration\ folder, check D:\TRMS\Configuration\

  2. Open connectionStrings.config in notepad.
  3. Update connectionString="data source=(local);Integrated Security=SSPI;initial catalog=Carousel50;MultipleActiveResultSets=true;"
    to read
    connectionString="data source=(local);Integrated Security=SSPI;MultipleActiveResultSets=true;initial catalog=Carousel50;"
  4. Save the file
  5. Restart IIS
  6. You should now be able to backup the database.

Additional Information

The TRMS engineering team plans to fix this issue for release in Carousel 7.0.3.  

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  • Bug Status: Pending
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