YOUR STORY PLAYS HERE
Home » Categories » Multiple Categories

Carousel Does Not Load when Logged in with Usernames that Contain Periods

Applies to

  • Carousel 7.0.8+ 

Symptoms

  • Server unavailable due to 404 error code when accessing Carousel

Cause

The IIS web server is optimizing the request to use the static file handler because the user's account details are accessed at CarouselAPI/users/<username>. In this case the username contains a period which IIS inferst to mean the request is for a static file such as an image.

Workaround

  1. Locate the API Web.config located in C:\TRMS\Web\CarouselAPI\Web.config or D:\TRMS\Web\CarouselAPI\Web.config.
  2. Find the <modules> element located under the <system.webServer> element (approx. line  number 74)
  3. Change <modules> to be <modules runAllManagedModulesForAllRequests="true">
  4. Save the Web.config
0 (0)
Article Rating (No Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Submitting a bug report to Tightrope
Viewed 2535 times since Thu, Jan 8, 2015
How do I adjust how often Dynamic Bulletins are rendered?
Viewed 1744 times since Wed, Nov 19, 2014
Resource25 / 25Live Calendars in Carousel 7.0
Viewed 2060 times since Fri, Jun 16, 2017
Carousel - Software - Server - Playing YouTube in Carousel (Unofficial)
Viewed 798 times since Tue, Sep 12, 2017
How do I change the order in which my bulletins play
Viewed 2586 times since Tue, Nov 4, 2014
Carousel Security Options
Viewed 564 times since Mon, Apr 16, 2018
Carousel - How to enable TLS in Carousel 7.3.0
Viewed 1419 times since Fri, Apr 13, 2018
Carousel 7.3.0 Released
Viewed 845 times since Fri, May 11, 2018
Carousel 7.1.1 Released
Viewed 452 times since Thu, Apr 5, 2018