YOUR STORY PLAYS HERE
Home » Categories » Multiple Categories

Carousel Does Not Load when Logged in with Usernames that Contain Periods

Applies to

  • Carousel 7.0.8+ 

Symptoms

  • Server unavailable due to 404 error code when accessing Carousel

Cause

The IIS web server is optimizing the request to use the static file handler because the user's account details are accessed at CarouselAPI/users/<username>. In this case the username contains a period which IIS inferst to mean the request is for a static file such as an image.

Workaround

  1. Locate the API Web.config located in C:\TRMS\Web\CarouselAPI\Web.config or D:\TRMS\Web\CarouselAPI\Web.config.
  2. Find the <modules> element located under the <system.webServer> element (approx. line  number 74)
  3. Change <modules> to be <modules runAllManagedModulesForAllRequests="true">
  4. Save the Web.config
0 (0)
Article Rating (No Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
Error from RabbitMQ about unreachable endpoints
Viewed 5154 times since Mon, Feb 16, 2015
Information Needed to Add or Renew Assurance on Your System
Viewed 1642 times since Thu, Jul 2, 2015
How do I adjust how often Dynamic Bulletins are rendered?
Viewed 1222 times since Wed, Nov 19, 2014
Where can I download Carousel virtual machine images?
Viewed 1390 times since Tue, Dec 8, 2015
How do I enable VLC for Carousel videos?
Viewed 4067 times since Mon, Sep 22, 2014
Licensing my server
Viewed 2227 times since Wed, Sep 17, 2014
Where are the Carousel installer log files located?
Viewed 759 times since Mon, Oct 17, 2016
My Brightsign Player is showing a black screen
Viewed 3487 times since Tue, Nov 4, 2014
My Live Video Input bulletin is not working (AVermedia PCIe Card)
Viewed 1928 times since Tue, Nov 11, 2014
My new Carousel player will not connect to my server
Viewed 2211 times since Tue, Nov 11, 2014