YOUR STORY PLAYS HERE
Home » Categories » Multiple Categories

Carousel Does Not Load when Logged in with Usernames that Contain Periods

Applies to

  • Carousel 7.0.8+ 

Symptoms

  • Server unavailable due to 404 error code when accessing Carousel

Cause

The IIS web server is optimizing the request to use the static file handler because the user's account details are accessed at CarouselAPI/users/<username>. In this case the username contains a period which IIS inferst to mean the request is for a static file such as an image.

Workaround

  1. Locate the API Web.config located in C:\TRMS\Web\CarouselAPI\Web.config or D:\TRMS\Web\CarouselAPI\Web.config.
  2. Find the <modules> element located under the <system.webServer> element (approx. line  number 74)
  3. Change <modules> to be <modules runAllManagedModulesForAllRequests="true">
  4. Save the Web.config
0 (0)
Article Rating (No Votes)
Rate this article
  • Icon PDFExport to PDF
  • Icon MS-WordExport to MS Word
Attachments Attachments
There are no attachments for this article.
Related Articles RSS Feed
My new Carousel player will not connect to my server
Viewed 3211 times since Tue, Nov 11, 2014
Channel Showing Black When Switching To Carousel
Viewed 2823 times since Mon, Jun 29, 2015
Carousel 7.1.1 Released
Viewed 280 times since Thu, Apr 5, 2018
Exporting a Single Bulletin as a Bulletin Package
Viewed 1519 times since Tue, Sep 1, 2015
Carousel 7 supported editions of Windows 10
Viewed 1048 times since Wed, Apr 19, 2017
Carousel Security Options
Viewed 356 times since Mon, Apr 16, 2018
My Brightsign Player is showing a black screen
Viewed 5501 times since Tue, Nov 4, 2014
Licensing my server
Viewed 2911 times since Wed, Sep 17, 2014
Remote Desktop Connection doesn’t work on Carousel 270 Hardware
Viewed 418 times since Tue, Mar 27, 2018